Hive Support Portal maintenance

Incident Report for Hive

Resolved

This incident has been resolved.
Posted Mar 26, 2024 - 15:41 GMT

Identified

Due to unscheduled maintenance, we are unable to facilitate support requests via the help.hive.hr portal at this time. Please contact support@hive.hr in the mean time if you require technical support.
Posted Mar 26, 2024 - 15:09 GMT