We are seeing much improved performance across the board with the latest changes. We'll continue monitoring our systems for now, and encourage you to reach out if you see continued issues.
Posted Apr 24, 2024 - 16:43 BST
Monitoring
We're pushing out the performance enhancements to our production environment, and monitoring our systems to ensure the issue is resolved. Thank you all again for your patience.
Posted Apr 24, 2024 - 15:21 BST
Update
Testing is still ongoing as we seek to check the full functionality of the platform. Thank you for your patience whilst we carry out this work.
Posted Apr 24, 2024 - 12:12 BST
Update
We have identified the performance bottleneck and are now thoroughly testing the changes required to fix the degradation.
Posted Apr 24, 2024 - 01:58 BST
Update
We are currently testing a fix for the issue, which appears to be related to our translation functionality.
Posted Apr 23, 2024 - 17:04 BST
Update
We believe we've identified the issue and are actively working on a potential fix.
Posted Apr 23, 2024 - 13:16 BST
Identified
We're investigating performance problems affecting certain customers, and are actively working on identifying the issue.