Survey Builder

Incident Report for Hive

Resolved

This incident has been resolved.
Posted Jun 22, 2023 - 18:20 BST

Monitoring

We've identified an issue affecting some customers when accessing the Survey Builder functionality. A fix has now been rolled out and we're monitoring.
Posted Jun 22, 2023 - 17:21 BST
This incident affected: Web Application.