Open Door Unavailable

Incident Report for Hive

Resolved

This incident has been resolved.
Posted Jan 07, 2021 - 11:01 GMT

Investigating

We've become aware of an issue when attempting to access Open Door and are currently investigating.
Posted Jan 07, 2021 - 09:57 GMT
This incident affected: Web Application.