Amazon Web Services partial outage

Incident Report for Hive

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 12:03 BST

Identified

Our cloud provider AWS are experiencing issues, which is impacting our services.

Please see their website for further details https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 10:50 BST
This incident affected: Web Application, AWS dynamodb-us-east-1, AWS cloudfront, and AWS iam.