Our cloud provide has now resolved their infrastructure issues, and we're actively rolling back our temporary workaround. No downtime is expected at this stage.
Posted Jul 16, 2026 - 13:50 BST
Update
We've released a temporary workaround whilst our cloud provider (AWS) address the underlying cause of the timeouts.
Posted Jul 16, 2026 - 10:55 BST
Update
We've identified a workaround and are working to release this as soon as possible whilst our cloud service provider addresses their connectivity issues.
Posted Jul 16, 2026 - 10:28 BST
Monitoring
The timeout issues are caused by our cloud provider Amazon Web Services (AWS), which is currently experiencing timeout issues across their global infrastructure. We're actively monitoring the situation and will update once we have more information.
Posted Jul 16, 2026 - 10:07 BST
Investigating
We're investigating timeout issues across our backend services.