Delays in surveying functionality

Incident Report for Hive

Resolved

All events have now been processed without further delays.
Posted Aug 18, 2026 - 15:02 BST

Identified

We're currently seeing delays in how the Hive platform processes survey-related events. You may notice survey invites and reminders going out later than scheduled, and new responses taking longer than usual to appear in your dashboards and reports.

No data has been lost. Responses submitted are being recorded as normal, and every delayed event is queued and will be processed automatically — nothing needs to be resent.

We've identified the cause and are working through a solution that will see the events processed imminently.
Posted Aug 18, 2026 - 14:38 BST
This incident affected: Web Application and AWS sqs-eu-west-1.